hedgewars/CMakeLists.txt
changeset 2413 d921d13a8546
parent 2406 2e757b32991e
child 2420 b7390a3040f8
--- a/hedgewars/CMakeLists.txt	Sat Oct 10 14:24:39 2009 +0000
+++ b/hedgewars/CMakeLists.txt	Sat Oct 10 14:26:50 2009 +0000
@@ -92,12 +92,12 @@
 
 
 #PASCAL FLAG SECTION
-set(pascal_compiler_flags ${noexecstack_flags} "-B" "-FE../bin" "-Fl../bin/" "-Cs2000000" "-vwi" "-fPIC" ${hwengine_project})
+set(pascal_compiler_flags ${noexecstack_flags} "-B" "-FE../bin" "-Fl../bin/" "-Cs2000000" "-vwi" ${hwengine_project})
 
 if(OPTIMIZATIONS)
 	set(pascal_compiler_flags "-O2" "-Xs" "-Nu" ${pascal_compiler_flags})
 	if(APPLE AND NOT universal_build)
-		set(pascal_compiler_flags "-CfSSE2" ${pascal_compiler_flags})	#instruction set for ppc is 7400
+		set(pascal_compiler_flags "-fPIC" "-CfSSE2" ${pascal_compiler_flags})	#instruction set for ppc is 7400
 	endif()			
 else(OPTIMIZATIONS)
 	set(pascal_compiler_flags "-O-" "-gl" "-dDEBUGFILE" "-pg" "-va" ${pascal_compiler_flags})