QTfrontend/CMakeLists.txt
branchcursor_issues
changeset 5189 dc1fe432b293
parent 5188 d0461bd6d45b
child 5204 e1a5f4d5d86a
--- a/QTfrontend/CMakeLists.txt	Sun Apr 17 22:16:36 2011 +0400
+++ b/QTfrontend/CMakeLists.txt	Fri Apr 29 13:56:38 2011 +0400
@@ -36,6 +36,10 @@
     else()
         set(HEDGEWARS_DATADIR ${CMAKE_INSTALL_PREFIX}/share/)
     endif()
+    #only the cocoa version of qt supports building 64 bit apps
+    if(APPLE AND (CMAKE_OSX_ARCHITECTURES MATCHES "x86_64*") AND (NOT QT_MAC_USE_COCOA))
+        message(FATAL_ERROR "Building the 64 bit version of Hedgewars *requires* the Cocoa variant of QT on Mac OS X")
+    endif()
 endif()