hedgewars/CMakeLists.txt
branchsdl2transition
changeset 9679 dfaa39674e1e
parent 9677 71626318f80e
child 9703 966d180184b4
--- a/hedgewars/CMakeLists.txt	Wed Nov 06 00:59:33 2013 +0400
+++ b/hedgewars/CMakeLists.txt	Tue Nov 05 23:33:23 2013 +0100
@@ -108,7 +108,7 @@
 
 
 #DEPENDECIES AND EXECUTABLES SECTION
-if(NOT ${BUILD_ENGINE_LIBRARY} AND APPLE)
+if(NOT ${BUILD_ENGINE_LIBRARY} AND APPLE AND ${USESDL12})
     #on OSX we need to provide the SDL_main() function when building as executable
     add_subdirectory(sdlmain)
     list(APPEND HW_LINK_LIBS SDLmain)