CMakeLists.txt
changeset 7819 dfc4b6cbe6ea
parent 7817 6cc558a69b58
child 7820 c1b491e03362
--- a/CMakeLists.txt	Thu Oct 25 11:57:06 2012 -0400
+++ b/CMakeLists.txt	Thu Oct 25 13:30:08 2012 -0400
@@ -182,7 +182,9 @@
 #get BUILD_TYPE and enable/disable optimisation
 if(CMAKE_BUILD_TYPE MATCHES "DEBUG")
     message(STATUS "Building Debug flavour")
-    set(pascal_flags "-O-" "-g" "-gl" "-gv" ${pascal_flags})
+    # for no obvious reason, -gv was causing broken behaviour
+    #set(pascal_flags "-O-" "-g" "-gl" "-gv" ${pascal_flags})
+    set(pascal_flags "-O-" "-g" "-gl" ${pascal_flags})
     set(haskell_flags "-Wall" "-debug" "-dcore-lint" "-fno-warn-unused-do-bind" ${haskell_flags})
 else()
     message(STATUS "Building Release flavour")