hedgewars/CMakeLists.txt
changeset 7029 efbe6400fc24
parent 6992 b8f3d8991e92
child 7031 d5ea24399a48
--- a/hedgewars/CMakeLists.txt	Sat May 05 19:04:59 2012 +0100
+++ b/hedgewars/CMakeLists.txt	Mon May 07 10:51:32 2012 +0200
@@ -91,7 +91,11 @@
     endif (APPLE)
 endif(BUILD_ENGINE_LIBRARY)
 
-find_program(fpc_executable fpc)
+IF(FPC)
+    set(fpc_executable ${FPC})
+ELSE()
+    find_program(fpc_executable fpc)
+ENDIF()
 
 if(fpc_executable)
     exec_program(${fpc_executable} ARGS "-iV" OUTPUT_VARIABLE fpc_output)
@@ -138,7 +142,7 @@
         message(FATAL_ERROR "Minimum required version of FreePascal is 2.6.0 on Mac OS X")
     endif()
 else()
-    message(FATAL_ERROR "No Pascal compiler found!")
+    message(FATAL_ERROR "No FreePascal compiler found!")
 endif()