hedgewars/CMakeLists.txt
changeset 7694 f40c65ae3eab
parent 7655 b993257902d3
child 7706 19ade14ecc29
--- a/hedgewars/CMakeLists.txt	Thu Sep 20 22:10:32 2012 +0200
+++ b/hedgewars/CMakeLists.txt	Thu Sep 20 22:17:02 2012 +0200
@@ -261,7 +261,8 @@
     add_dependencies(${engine_output_name} lua)
 endif()
 
-if(NOT APPLE)
+#fpc < 2.6 has a few bugs in updating inline functions, so we have to compile all engine every time as workaround
+if(fpc_version LESS "020600")
     if(NO_VIDEOREC OR NOT ${FFMPEG_FOUND})
         add_dependencies(${engine_output_name} ENGINECLEAN)
     endif()