project_files/hwc/CMakeLists.txt
changeset 14476 f86bd14a7613
parent 14461 9844450389a4
child 15361 5c0479d0ed5b
--- a/project_files/hwc/CMakeLists.txt	Wed Dec 19 05:50:02 2018 +0100
+++ b/project_files/hwc/CMakeLists.txt	Wed Dec 19 19:00:29 2018 -0500
@@ -37,6 +37,9 @@
 list(REMOVE_ITEM engine_sources_pas "${CMAKE_SOURCE_DIR}/hedgewars/pas2cSystem.pas")
 list(REMOVE_ITEM engine_sources_pas "${CMAKE_SOURCE_DIR}/hedgewars/pas2cRedo.pas")
 list(REMOVE_ITEM engine_sources_pas "${CMAKE_SOURCE_DIR}/hedgewars/hwLibrary.pas")
+if(NOVIDEOREC)
+	list(REMOVE_ITEM engine_sources_pas "${CMAKE_SOURCE_DIR}/hedgewars/uVideoRec.pas")
+endif()
 if(NOT GL2)
     list(REMOVE_ITEM engine_sources_pas "${CMAKE_SOURCE_DIR}/hedgewars/uMatrix.pas")
 endif()