hedgewars/CMakeLists.txt
changeset 89 f9db56409a86
parent 75 d2b737858ff7
child 95 1ef5e2c41115
--- a/hedgewars/CMakeLists.txt	Wed Jul 26 13:44:11 2006 +0000
+++ b/hedgewars/CMakeLists.txt	Thu Jul 27 15:24:14 2006 +0000
@@ -39,7 +39,6 @@
 	message(FATAL_ERROR "No Pascal compiler found!")
 endif (NOT pascal_compiler)
 
-add_custom_target(hwengine ALL
-	${pascal_compiler} ${pascal_compiler_flags})
+add_custom_command(COMMAND ${pascal_compiler} TARGET hwengine OUTPUTS hwengine ARGS ${pascal_compiler_flags})
 
-install_targets(/bin hwengine)
+install(PROGRAMS "hwengine${CMAKE_EXECUTABLE_SUFFIX}" DESTINATION bin)