QTfrontend/CMakeLists.txt
changeset 15451 3102d95a870e
parent 15449 6e09555b25b4
child 15555 107170c05bac
--- a/QTfrontend/CMakeLists.txt	Wed Oct 09 18:08:37 2019 +0200
+++ b/QTfrontend/CMakeLists.txt	Wed Oct 09 18:12:09 2019 +0200
@@ -213,9 +213,9 @@
 
 #when debugging, always prompt a console to see fronted messages
 #TODO: check it doesn't interfere on UNIX
-if(CMAKE_BUILD_TYPE MATCHES "Release" OR CMAKE_BUILD_TYPE MATCHES "RelWithDebInfo")
+if(CMAKE_BUILD_TYPE STREQUAL "Release" OR CMAKE_BUILD_TYPE STREQUAL "RelWithDebInfo")
     set(console_access "WIN32")
-endif(CMAKE_BUILD_TYPE MATCHES "Release" OR CMAKE_BUILD_TYPE MATCHES "RelWithDebInfo")
+endif(CMAKE_BUILD_TYPE STREQUAL "Release" OR CMAKE_BUILD_TYPE STREQUAL "RelWithDebInfo")
 
 add_executable(hedgewars ${console_access}
     ${hwfr_src}