project_files/hwc/CMakeLists.txt
changeset 11791 3127b0fece81
parent 11681 8fca9fd31357
child 11794 64bbe89e59d6
--- a/project_files/hwc/CMakeLists.txt	Tue May 03 01:13:41 2016 +0200
+++ b/project_files/hwc/CMakeLists.txt	Mon May 02 22:52:21 2016 -0400
@@ -64,7 +64,13 @@
                -d ENDIAN_LITTLE
                -d DEBUGFILE)
 if(BUILD_ENGINE_JS)
-    set(pas2c_args ${pas2c_args} -d WEBGL -d HWLIBRARY)
+    set(pas2c_args ${pas2c_args} -d WEBGL)
+endif()
+if(BUILD_ENGINE_LIBRARY)
+    set(pas2c_args ${pas2c_args} -d HWLIBRARY)
+endif()
+if(GL2)
+    set(pas2c_args ${pas2c_args} -d GL2)
 endif()
 
 #invoke pas2c on main module, it will call all the others