rust/hedgewars-server/Cargo.toml
changeset 15833 3511bacbd763
parent 15831 7d0f747afcb8
child 15936 c5c53ebb2d91
--- a/rust/hedgewars-server/Cargo.toml	Tue Feb 01 20:58:35 2022 +0300
+++ b/rust/hedgewars-server/Cargo.toml	Thu Feb 03 01:48:31 2022 +0300
@@ -5,7 +5,7 @@
 authors = [ "Andrey Korotaev <a.korotaev@hedgewars.org>" ]
 
 [features]
-official-server = []
+official-server = ["mysql_async", "sha1"]
 default = []
 
 [dependencies]
@@ -16,11 +16,13 @@
 env_logger = "0.8"
 getopts = "0.2"
 log = "0.4"
+mysql_async = { version = "0.29.0", optional = true }
 nom = "7.1"
 rand = "0.8"
 serde = "1.0"
 serde_yaml = "0.8"
 serde_derive = "1.0"
+sha1 = { version = "0.10.0", optional = true }
 slab = "0.4"
 tokio = { version = "1.16", features = ["full"]}