rust/hedgewars-server/Cargo.toml
changeset 15936 c5c53ebb2d91
parent 15833 3511bacbd763
child 15986 cd8392e52165
--- a/rust/hedgewars-server/Cargo.toml	Thu Mar 23 23:41:26 2023 +0300
+++ b/rust/hedgewars-server/Cargo.toml	Fri Mar 24 03:26:08 2023 +0300
@@ -5,7 +5,8 @@
 authors = [ "Andrey Korotaev <a.korotaev@hedgewars.org>" ]
 
 [features]
-official-server = ["mysql_async", "sha1"]
+tls-connections = ["tokio-native-tls"]
+official-server = ["mysql_async", "sha1", "tls-connections"]
 default = []
 
 [dependencies]
@@ -25,6 +26,7 @@
 sha1 = { version = "0.10.0", optional = true }
 slab = "0.4"
 tokio = { version = "1.16", features = ["full"]}
+tokio-native-tls = { version = "0.3", optional = true }
 
 hedgewars-network-protocol = { path = "../hedgewars-network-protocol" }