CMakeLists.txt
changeset 7256 5b97b9946cde
parent 7233 225179f64fd8
child 7264 4c438ad3eddc
--- a/CMakeLists.txt	Sun Jun 17 14:13:19 2012 +0400
+++ b/CMakeLists.txt	Sun Jun 17 16:32:44 2012 +0200
@@ -52,17 +52,19 @@
 ENDIF(NOT BUILD_ENGINE_LIBRARY)
 set(target_dir "bin")
 
-
 #bundle .app setup
-if(APPLE)
-    set(CMAKE_FIND_FRAMEWORK "FIRST")
-
+if(APPLE OR CROSSAPPLE)
     #paths for creating the bundle
     set(bundle_name Hedgewars.app)
     set(frameworks_dir ${bundle_name}/Contents/Frameworks/)
     set(CMAKE_INSTALL_PREFIX ${bundle_name}/Contents/MacOS/)
     set(DATA_INSTALL_DIR "../Resources/")
     set(target_dir ".")
+    set(minimum_macosx_version "10.6")
+endif()
+
+if(APPLE)
+    set(CMAKE_FIND_FRAMEWORK "FIRST")
 
     #what system are we building for
     set(minimum_macosx_version $ENV{MACOSX_DEPLOYMENT_TARGET})