QTfrontend/CMakeLists.txt
branchflibqtfrontend
changeset 8126 5bfa1b2025d6
parent 8100 0e6fadf81a2c
parent 8104 09c38cdf380d
child 8208 171da01bd04d
--- a/QTfrontend/CMakeLists.txt	Mon Nov 26 00:06:42 2012 +0400
+++ b/QTfrontend/CMakeLists.txt	Mon Nov 26 00:09:54 2012 +0400
@@ -164,8 +164,13 @@
     link_directories(${EXECUTABLE_OUTPUT_PATH})
 endif()
 
+#when debugging, always prompt a console to see fronted messages
+#TODO: check it doesn't interfere on UNIX
+if(CMAKE_BUILD_TYPE MATCHES "RELEASE")
+    set(console_access "WIN32")
+endif(CMAKE_BUILD_TYPE MATCHES "RELEASE")
 
-add_executable(hedgewars WIN32
+add_executable(hedgewars ${console_access}
     ${hwfr_src}
     ${hwfr_moc_srcs}
     ${hwfr_hdrs}