QTfrontend/CMakeLists.txt
changeset 8082 675372256a01
parent 8078 ea7541f77944
child 8083 2edbd01a04a0
--- a/QTfrontend/CMakeLists.txt	Tue Nov 20 22:08:08 2012 +0100
+++ b/QTfrontend/CMakeLists.txt	Wed Nov 21 01:48:10 2012 +0100
@@ -59,7 +59,6 @@
     endif()
 endif()
 
-
 configure_file(${CMAKE_CURRENT_SOURCE_DIR}/hwconsts.cpp.in ${CMAKE_CURRENT_BINARY_DIR}/hwconsts.cpp)
 
 file(GLOB NetCpp net/*.cpp)
@@ -158,6 +157,12 @@
     endif()
 endif()
 
+if(BUILD_ENGINE_LIBRARY)
+    add_definitions(-DHWLIBRARY)
+    set(HW_LINK_LIBS hwengine ${HW_LINK_LIBS})
+    link_directories(${EXECUTABLE_OUTPUT_PATH})
+endif()
+
 
 add_executable(hedgewars WIN32
     ${hwfr_src}