QTfrontend/CMakeLists.txt
branchsdl2transition
changeset 9701 7f6786625667
parent 9679 dfaa39674e1e
child 9703 966d180184b4
--- a/QTfrontend/CMakeLists.txt	Sun Nov 10 14:04:15 2013 +0400
+++ b/QTfrontend/CMakeLists.txt	Mon Nov 11 00:15:20 2013 +0400
@@ -205,10 +205,20 @@
 list(APPEND HW_LINK_LIBS
     physfs physlayer
     ${QT_LIBRARIES}
-    ${SDL_LIBRARY}
-    ${SDLMIXER_LIBRARY}
     )
 
+if(USESDL12)
+    list(APPEND HW_LINK_LIBS
+        ${SDL_LIBRARY}
+        ${SDLMIXER_LIBRARY}
+        )
+else()
+    list(APPEND HW_LINK_LIBS
+        ${SDL2_LIBRARY}
+        ${SDL2MIXER_LIBRARY}
+        )
+endif()
+
 if(WIN32 AND NOT UNIX)
     if(NOT SDL_LIBRARY)
         list(APPEND HW_LINK_LIBS SDL)