CMakeLists.txt
changeset 8688 88a6114a318c
parent 8687 5b6ad1bd6ace
child 8698 6714499ecdeb
--- a/CMakeLists.txt	Thu Mar 07 10:16:21 2013 +0100
+++ b/CMakeLists.txt	Thu Mar 07 11:55:00 2013 +0100
@@ -333,12 +333,7 @@
     list(APPEND pascal_flags "-XLAphysfs=${physfs_output_name}" "-dPHYSFS_INTERNAL")
 endif()
 
-if(NOT NOVIDEOREC)
-    find_package_or_disable(FFMPEG NOVIDEOREC)
-else()
-    message(STATUS "Video recording disabled")
-    set(FFMPEG_FOUND false)
-endif()
+find_package_or_disable_msg(FFMPEG NOVIDEOREC "Video recording will not be built")
 
 #physfs helper library
 add_subdirectory(misc/libphyslayer)