project_files/hwc/CMakeLists.txt
changeset 11679 8f5db41471f4
parent 11661 7d483d400f8d
child 11681 8fca9fd31357
--- a/project_files/hwc/CMakeLists.txt	Sat Apr 23 13:48:30 2016 -0400
+++ b/project_files/hwc/CMakeLists.txt	Sat Apr 23 13:52:30 2016 -0400
@@ -79,6 +79,10 @@
 add_custom_target(engine_c DEPENDS ${engine_sources})
 
 
+if(BUILD_ENGINE_JS)
+    add_flag_append(CMAKE_C_FLAGS "-s ABORTING_MALLOC=0")
+endif()
+
 #compile the c files
 add_definitions(-DPAS2C)
 add_definitions(-Werror=incompatible-pointer-types)