QTfrontend/CMakeLists.txt
branchui-scaling
changeset 15663 d92eeb468dad
parent 15451 3102d95a870e
child 15555 107170c05bac
--- a/QTfrontend/CMakeLists.txt	Wed Jul 31 23:14:27 2019 +0200
+++ b/QTfrontend/CMakeLists.txt	Fri Jul 03 23:51:47 2020 +0200
@@ -213,9 +213,9 @@
 
 #when debugging, always prompt a console to see fronted messages
 #TODO: check it doesn't interfere on UNIX
-if(CMAKE_BUILD_TYPE MATCHES "RELEASE" OR CMAKE_BUILD_TYPE MATCHES "RELWITHDEBINFO")
+if(CMAKE_BUILD_TYPE STREQUAL "Release" OR CMAKE_BUILD_TYPE STREQUAL "RelWithDebInfo")
     set(console_access "WIN32")
-endif(CMAKE_BUILD_TYPE MATCHES "RELEASE" OR CMAKE_BUILD_TYPE MATCHES "RELWITHDEBINFO")
+endif(CMAKE_BUILD_TYPE STREQUAL "Release" OR CMAKE_BUILD_TYPE STREQUAL "RelWithDebInfo")
 
 add_executable(hedgewars ${console_access}
     ${hwfr_src}