project_files/hwc/CMakeLists.txt
branchwebgl
changeset 9267 dbd18257be8f
parent 9264 21df1a0ec9ed
parent 9259 872dd30deb7b
child 9976 a9c8f3f11c71
--- a/project_files/hwc/CMakeLists.txt	Wed Jun 19 00:52:21 2013 +0400
+++ b/project_files/hwc/CMakeLists.txt	Wed Jun 19 00:52:39 2013 +0400
@@ -27,6 +27,11 @@
 list(REMOVE_ITEM engine_sources_pas "${CMAKE_SOURCE_DIR}/hedgewars/pas2cRedo.pas")
 list(REMOVE_ITEM engine_sources_pas "${CMAKE_SOURCE_DIR}/hedgewars/hwLibrary.pas")
 
+#remove and readd hwengine so that it is compiled first, compiling every other file in the process
+list(REMOVE_ITEM engine_sources_pas ${CMAKE_SOURCE_DIR}/hedgewars/hwengine.pas)
+list(APPEND engine_sources_pas ${CMAKE_SOURCE_DIR}/hedgewars/hwengine.pas)
+
+#process files .pas -> .c
 foreach(sourcefile ${engine_sources_pas})
     get_filename_component(sourcename ${sourcefile} NAME_WE) #drops .pas
     list(APPEND engine_sources "${CMAKE_CURRENT_BINARY_DIR}/${sourcename}.c")