--- a/misc/libphysfs/CMakeLists.txt Thu Apr 04 14:37:19 2013 +0200
+++ b/misc/libphysfs/CMakeLists.txt Tue Jun 04 22:28:12 2013 +0200
@@ -35,6 +35,15 @@
include(CheckCSourceCompiles)
+# 32bit platforms won't link unless this is set
+# although Windows doesn't like it
+if(NOT WINDOWS)
+ if(CMAKE_SIZEOF_VOID_P LESS 8)
+ add_definitions(-DPHYSFS_NO_64BIT_SUPPORT=1)
+ endif(CMAKE_SIZEOF_VOID_P LESS 8)
+endif(NOT WINDOWS)
+
+
if(MACOSX)
# Fallback to older OS X on PowerPC to support wider range of systems...
if(CMAKE_OSX_ARCHITECTURES MATCHES ppc)